CategoriasHosting

¿Cómo actualizar la versión PHP de tu WordPress?

Algunos plugins de WordPress están empezando a mostrar mensajes de alerta sobre la versión de PHP como el que muestra Ninja Forms:

La versión de PHP 7.2 que hasta hace poco era una novedad, se queda obsoleta en breve y tendremos que actualizar a la siguiente, 7.3. Con cada nuevo cambio, todos los programadores tienen que adaptar sus aplicaciones a los nuevos códigos y normas.

El cambio de la versión de PHP es muy sencillo gracias al selector de PHP que tienes disponible en el panel de control. Conseguir que tu web siga funcionando como hasta ahora puede ser un poco más complicado.

¿Por qué tenemos que actualizar?

En lugar de detallar las ventajas como se suele hacer en estos casos, te daré una razón más sólida: no tienes opción.

Si una web utiliza PHP como lenguaje de programación, tienes que mantenerla actualizanda de forma constante o alguien terminará hackeándola para tratar de conseguir algún beneficio.

De todos modos, aquí tienes una muy buena razón para actualizar: las nuevas versiones de PHP hacen que tu web cargue más rápido, con lo que sumas puntos en la carrera por posicionar en Google.

Preparando el cambio de versión PHP

Este paso no es necesario pero sí recomendado. El código de tu web no se cambiará, pero antes de hacer cualquier trabajo sobre una web, es bueno y barato hacer una copia de seguridad.

En el vídeo que tienes en la portada de www.honesting.es puedes ver cómo hacerlo fácilmente con Softaculous, a partir del minuto 16.

Comprobando si tu web y plugins son compatibles con la nueva versión de PHP

En WordPress, hay un plugin para todo. Incluso un plugin que comprueba otros plugins. En esta guía, utilizaré PHP Compatibility Checker de WP Engine en su versión 1.5.0.

Una vez instalado, muestra esta pantalla:

Elige la versión de PHP que quieres comprobar (7.3), explorar todos y haz click en escanear.

Nota: no dejes plugins inactivos en tu WordPress, si no los usas, bórralos. Liberas espacio en el disco y evitas problemas o confusiones. Un hosting limpio es más fácil de mantener seguro.

Tardará un rato ya que está comprodando todo el código línea a línea. Una vez termine, mostrará un resultado como este:

Algunos plugins, generarán un error diciendo que:

El plugin/tema se ha omitido ya que es demasiado grande para explorar antes de que el servidor finalice el proceso.

Como por ejemplo, el que era de esperar, Jetpack by WordPress.com

Si alguno te aparece como que no es compatible, tienes que buscar un reemplazo para el mismo antes de continuar.

Cambio de versión de PHP

El último paso, es el más sencillo en la práctica pero el que debe hacerse con mayor atención, ya que puede generar que tu web deje de funcionar. Desde tu panel de control, entra en el Selector de PHP y elige la nueva versión de PHP, 7.3 en este caso.

Luego haz click en Guardar.

Comprueba que tu web cargue bien. Si lo hace, ya habrás terminado. Si aparece una página en blanco, significa que te falta algún módulo por activar. En ese caso:

Solución de problemas con el cambio de versión PHP

  1. Vuelve a la versión anterior de PHP que te funcionaba haciendo lo mismo, elige 7.1 o la que tuvieras y haz click en Guardar.
  2. Abre una nueva pestaña en el navegador con el selector de PHP, cambia la versión a la deseada y revisa que tengas activos los mismos módulos en la versión vieja y en la nueva.
  3. Una vez terminado, haz click en Guardar.

En caso de necesitar ayuda adicional, puedes enviar una consulta desde tu cuenta.

Publicado por Aitor Serra Martín

Administrador de servidores y desarrollador de páginas web.

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *