Hemos procedido a actualizar todos los servidores con las últimas versiones estables del servidor web (Apache) y del entorno de programación PHP.

No es necesario que hagas ningún cambio en tu plan salvo que tengas algún php.ini personalizado.

 

Errores en Joomla

Según parece, algunas instalaciones viejas de Joomla muestran el siguiente error tras la actualización:


Strict Standards: Non-static method JLoader::import() should not be called statically in

 

Por lo que hemos podido leer, es un problema con cómo Joomla maneja este tipo de entradas. No lo hace cumpliendo los estándares del nuevo PHP 5.4 y de ahí el error. La solución pasa por crear un fichero php.ini personalizado y desactivar ese tipo de errores:

Abre un editor de texto y escribe las siguienteslíneas:


error_reporting   =   E_ALL & ~E_NOTICE      ; Show all errors except for notices
display_errors   =   Off   ; Print out errors (as a part of the output)

 

Guárdalo con el nombre php.ini

Cópialo a la carpeta donde tengas instalado Joomla.

Opcionalmente, contacta con el encargado de la web para que revise si hay alguna actualización pendiente o algún módulo que necesita actualizarse.

 

Errores en Drupal

En este gestor de contenidos, hemos detectado en algunos casos que da un error de 500 Internal server error. La solución pasa por borrar el fichero php.ini con las viejas configuraciones.

 

Errores de “Internal Server Error”

Borra el fichero php.ini que seguramente tengas en tu carpeta www o borra la línea:

register_globals = On;